What do I need to run Periscope on my device?

2 Dec

To use Periscope, you need an Apple device running iOS 7 or greater or an Android device running 4.4 (aka Kit Kat) or higher. Your Android device will need both front and back cameras in order to be compatible.

Some devices cannot support the required OS due to hardware limitations. If your device isn’t supported, you can always watch broadcasts on the web. Go here for more info.
Source: https://help.periscope.tv/

Comments

comments

Luigi

IT. Internet & E-Commerce. Entrepreneur. Social Media. Online Marketing.

Leave a Reply